APKBUILD examples:Git checkout

source="http://dev.alpinelinux.org/archive/configshell/$_pkgname-$_pkgver.tar.gz"
builddir="$srcdir/$_pkgname-fb-v$_pkgver"

_giturl="https://github.com/agrover/configshell-fb"
_gittag="v$_pkgver"


snapshot() {
	mkdir -p "$srcdir"
	cd "${SRCDEST:-$srcdir}"
	if ! [ -d $_pkgname-fb.git ]; then
		git clone --bare  $_giturl || return 1
		cd $_pkgname-fb.git
	else
		cd $_pkgname-fb.git
		git fetch || return 1
	fi
	
	git archive --prefix=$_pkgname/ -o "$SRCDEST"/$_pkgname-$_pkgver.tar.gz $_gittag
	scp "$SRCDEST"/$_pkgname-$_pkgver.tar.gz dev.alpinelinux.org:/archive/$_pkgname/
}
This article is issued from Alpinelinux. The text is licensed under Creative Commons - Attribution - Sharealike. Additional terms may apply for the media files.